Kayak Fishing Adventures on Big Waterís Edge  

Go Back   Kayak Fishing Adventures on Big Waterís Edge > Kayak Fishing Forum - Message Board > General Kayak Fishing Discussion

Reply
 
Thread Tools Display Modes
Old 02-18-2020, 12:09 AM   #1
tak100
Recruit
 
Join Date: Jan 2018
Location: Long Beach, CA
Posts: 58
Fish Finder Trouble

I have a Garmin Striker 4cv which has worked great for 2.5 seasons.

The unit will power up with no transducer plugged in but anytime the transducer is plugged in the unit shuts off right after booting up.

Battery is checking out fine.

Bad transducer?

Anything else to check before I buy a replacement transducer?

Anyone had something similar happen?

Thanks in advance for sharing.
tak100 is offline   Reply With Quote
Old 02-18-2020, 06:45 AM   #2
ProfessorLongArms
Senior Member
 
ProfessorLongArms's Avatar
 
Join Date: Sep 2017
Location: Highland Park, CA
Posts: 256
Thats damn weird... not sure how they are outside of warranty, but it might be worth checking in with their customer support.

Iíve always been amazed at how good customer support departments will do stuff for you even if they donít have to if you present your problem in a curious, unassuming and above all really nice way, then ask them if thereís anything they can do for you.

Most of the stories I read about transducer problems online when I was researching this exact model involved CS just sending out a new transducer sight unseen without making them ship theirs, Though Iím pretty sure that was on a defective brand new unit so that might not be the case here.
ProfessorLongArms is offline   Reply With Quote
Old 02-18-2020, 09:58 AM   #3
Iceman
Administrator
 
Iceman's Avatar
 
Join Date: Mar 2005
Location: 1-2 miles off the point
Posts: 6,925
it does seem like this would be the battery under load is insufficient voltage, try another battery even if it seems to be ok.
__________________
Iceman is offline   Reply With Quote
Old 02-18-2020, 10:36 PM   #4
tak100
Recruit
 
Join Date: Jan 2018
Location: Long Beach, CA
Posts: 58
Thanks for the advice I will give both things a try.
tak100 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -8. The time now is 11:56 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
© 2002 Big Water's Edge. All rights reserved.